Fc14 won't boot with 2gb ram

From PrgmrWiki

just spent an inordinate amount of time on this. with

memory=2048

in the xen config, I get the following error:

with

memory=1024

the exact same setup works just fine.



root (hd0,0) 
 Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.38.6-27.fc15.i686.PAE console=hvc0 root=/dev/xvda1 ro 
selinux=0
initrd /boot/initramfs-2.6.38.6-27.fc15.i686.PAE.img

close blk: backend at /local/domain/0/backend/vbd/207/51712
close blk: backend at /local/domain/0/backend/vbd/207/51776
close blk: backend at /local/domain/0/backend/vbd/207/51792
[    0.000000] Reserving virtual address space above 0xf5800000
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 2.6.38.6-27.fc15.i686.PAE (mockbuild@x86-04.phx2.fedoraproject.org) (gcc version 4.6.0 20110428 (Red Hat 4.6.0-6) (GCC) ) #1 SMP Sun May 15 17:39:47 UTC 2011
[    0.000000] ACPI in unprivileged domain disabled
[    0.000000] released 0 pages of unused memory
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  Xen: 0000000000000000 - 00000000000a0000 (usable)
[    0.000000]  Xen: 00000000000a0000 - 0000000000100000 (reserved)
[    0.000000]  Xen: 0000000000100000 - 0000000080800000 (usable)
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] DMI not present or invalid.
[    0.000000] last_pfn = 0x80800 max_arch_pfn = 0x1000000
[    0.000000] init_memory_mapping: 0000000000000000-000000002c9fe000
[    0.000000] RAMDISK: 00e73000 - 0276d000
[    0.000000] 1342MB HIGHMEM available.
[    0.000000] 713MB LOWMEM available.
[    0.000000]   mapped low ram: 0 - 2c9fe000
[    0.000000]   low ram: 0 - 2c9fe000
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA      0x00000010 -> 0x00001000
[    0.000000]   Normal   0x00001000 -> 0x0002c9fe
[    0.000000]   HighMem  0x0002c9fe -> 0x00080800
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[2] active PFN ranges
[    0.000000]     0: 0x00000010 -> 0x000000a0
[    0.000000]     0: 0x00000100 -> 0x00080800
[    0.000000] Using APIC driver default
[    0.000000] SFI: Simple Firmware Interface v0.81 http://simplefirmware.org
[    0.000000] SMP: Allowing 4 CPUs, 0 hotplug CPUs
[    0.000000] Local APIC disabled by BIOS -- you can enable it with "lapic"
[    0.000000] APIC: disable apic facility
[    0.000000] APIC: switched to apic NOOP
[    0.000000] PM: Registered nosave memory: 00000000000a0000 - 0000000000100000
[    0.000000] Allocating PCI resources starting at 80800000 (gap: 80800000:7f800000)
[    0.000000] Booting paravirtualized kernel on Xen
[    0.000000] Xen version: 3.4.1-rc8 (preserve-AD)
[    0.000000] setup_percpu: NR_CPUS:64 nr_cpumask_bits:64 nr_cpu_ids:4 nr_node_ids:1
[    0.000000] PERCPU: Embedded 13 pages/cpu @eb9ad000 s31040 r0 d22208 u53248
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 522111
[    0.000000] Kernel command line: console=hvc0 root=/dev/xvda1 ro selinux=0
[    0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Initializing CPU#0
[    0.000000] allocated 10526400 bytes of page_cgroup
[    0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.000000] Initializing HighMem for node 0 (0002c9fe:00080800)
[    0.000000] Memory: 2031580k/2105344k available (4028k kernel code, 65124k reserved, 2570k data, 592k init, 1366024k highmem)
[    0.000000] virtual kernel memory layout:
[    0.000000]     fixmap  : 0xf4d75000 - 0xf57ff000   (10792 kB)
[    0.000000]     pkmap   : 0xf4a00000 - 0xf4c00000   (2048 kB)
[    0.000000]     vmalloc : 0xed1fe000 - 0xf49fe000   ( 120 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xec9fe000   ( 713 MB)
[    0.000000]       .init : 0xc0a72000 - 0xc0b06000   ( 592 kB)
[    0.000000]       .data : 0xc07ef342 - 0xc0a71c00   (2570 kB)
[    0.000000]       .text : 0xc0400000 - 0xc07ef342   (4028 kB)
[    0.000000] SLUB: Genslabs=15, HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000] 	RCU dyntick-idle grace-period acceleration is enabled.
[    0.000000] 	RCU-based detection of stalled CPUs is disabled.
[    0.000000] NR_IRQS:2304
[    0.000000] Console: colour dummy device 80x25
[    0.000000] console [tty0] enabled
[    0.000000] console [hvc0] enabled
[    0.000000] installing Xen timer for CPU 0
[    0.000000] Detected 2110.816 MHz processor.
[    0.000999] Calibrating delay loop (skipped), value calculated using timer frequency.. 4221.63 BogoMIPS (lpj=2110816)
[    0.000999] pid_max: default: 32768 minimum: 301
[    0.000999] Security Framework initialized
[    0.000999] SELinux:  Disabled at boot.
[    0.000999] Mount-cache hash table entries: 512
[    0.001108] Initializing cgroup subsys ns
[    0.001122] ns_cgroup deprecated: consider using the 'clone_children' flag without the ns_cgroup.
[    0.001139] Initializing cgroup subsys cpuacct
[    0.001198] Initializing cgroup subsys memory
[    0.001238] Initializing cgroup subsys devices
[    0.001250] Initializing cgroup subsys freezer
[    0.001260] Initializing cgroup subsys net_cls
[    0.001271] Initializing cgroup subsys blkio
[    0.001385] CPU: Physical Processor ID: 0
[    0.001394] CPU: Processor Core ID: 0
[    0.001691] SMP alternatives: switching to UP code
[    0.001999] ftrace: allocating 23362 entries in 46 pages
[    0.002179] Performance Events: 
[    0.002195] no APIC, boot with the "lapic" boot parameter to force-enable it.
[    0.002208] no hardware sampling interrupt available.
[    0.002241] Broken PMU hardware detected, using software events only.
[    0.002895] NMI watchdog disabled (cpu0): hardware events not enabled
[    0.003025] installing Xen timer for CPU 1
[    0.003083] SMP alternatives: switching to SMP code
[    0.000999] Initializing CPU#1
[    0.004173] NMI watchdog disabled (cpu1): hardware events not enabled
[    0.004311] installing Xen timer for CPU 2
[    0.000999] Initializing CPU#2
[    0.005051] NMI watchdog disabled (cpu2): hardware events not enabled
[    0.005245] installing Xen timer for CPU 3
[    0.000999] Initializing CPU#3
[    0.005446] NMI watchdog disabled (cpu3): hardware events not enabled
[    0.005463] Brought up 4 CPUs
[    0.006098] devtmpfs: initialized
[    0.007867] atomic64 test passed for i586+ platform with CX8 and with SSE
[    0.007922] Grant table initialized
[    0.027839] Time: 165:165:165  Date: 165/165/65
[    0.028010] NET: Registered protocol family 16
[    0.028210] Extended Config Space enabled on 0 nodes
[    0.029640] PCI: setting up Xen PCI frontend stub
[    0.032125] bio: create slab <bio-0> at 0
[    0.032228] ACPI: Interpreter disabled.
[    0.049050] xen_balloon: Initialising balloon driver.
[    0.049053] last_pfn = 0x80800 max_arch_pfn = 0x1000000
[    0.049127] vgaarb: loaded
[    0.050015] SCSI subsystem initialized
[    0.050246] usbcore: registered new interface driver usbfs
[    0.050280] usbcore: registered new interface driver hub
[    0.050324] usbcore: registered new device driver usb
[    0.050324] PCI: System does not support PCI
[    0.050324] PCI: System does not support PCI
[    0.050324] NetLabel: Initializing
[    0.050324] NetLabel:  domain hash size = 128
[    0.050324] NetLabel:  protocols = UNLABELED CIPSOv4
[    0.050324] NetLabel:  unlabeled traffic allowed by default
[    0.050378] Switching to clocksource xen
[    0.053837] Switched to NOHz mode on CPU #0
[    0.054019] Switched to NOHz mode on CPU #3
[    0.054025] Switched to NOHz mode on CPU #2
[    0.054033] Switched to NOHz mode on CPU #1
[    0.064075] pnp: PnP ACPI: disabled
[    0.067298] NET: Registered protocol family 2
[    0.067435] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.067743] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
[    0.068494] TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
[    0.068840] TCP: Hash tables configured (established 131072 bind 65536)
[    0.068856] TCP reno registered
[    0.068866] UDP hash table entries: 512 (order: 2, 16384 bytes)
[    0.068889] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[    0.069008] NET: Registered protocol family 1
[    0.069376] Trying to unpack rootfs image as initramfs...
[    0.165472] rootfs image is not initramfs (junk in compressed archive); looks like an initrd
[    0.244682] Freeing initrd memory: 25576k freed
[    0.259156] platform rtc_cmos: registered platform RTC device (no PNP device found)
[    0.260008] apm: BIOS not found.
[    0.260320] audit: initializing netlink socket (disabled)
[    0.260352] type=2000 audit(1313283492.401:1): initialized
[    0.272306] highmem bounce pool size: 64 pages
[    0.272330] HugeTLB registered 2 MB page size, pre-allocated 0 pages
[    0.274960] VFS: Disk quotas dquot_6.5.2
[    0.275193] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.276256] msgmni has been set to 1365
[    0.277090] NET: Registered protocol family 38
[    0.277176] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.277284] io scheduler noop registered
[    0.277293] io scheduler deadline registered
[    0.277321] io scheduler cfq registered (default)
[    0.277428] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[    0.277475] pciehp: PCI Express Hot Plug Controller Driver version: 0.4
[    0.277486] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    0.277710] isapnp: Scanning for PnP cards...
[    0.635303] isapnp: No Plug & Play device found
[    0.636165] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    0.639340] Non-volatile memory driver v1.3
[    0.639352] Linux agpgart interface v0.103
[    0.641431] brd: module loaded
[    0.642371] loop: module loaded
[    0.642584] Fixed MDIO Bus: probed
[    0.642665] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.642700] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    0.642724] uhci_hcd: USB Universal Host Controller Interface driver
[    0.642805] i8042: PNP: No PS/2 controller found. Probing ports directly.
[    0.643709] mousedev: PS/2 mouse device common for all mice
[    0.644108] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
[    0.644174] rtc_cmos: probe of rtc_cmos failed with error -38
[    0.644298] device-mapper: uevent: version 1.0.3
[    0.644421] device-mapper: ioctl: 4.19.1-ioctl (2011-01-07) initialised: dm-devel@redhat.com
[    0.644482] cpuidle: using governor ladder
[    0.644490] cpuidle: using governor menu
[    0.644789] usbcore: registered new interface driver usbhid
[    0.644799] usbhid: USB HID core driver
[    0.644836] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[    0.645102] ip_tables: (C) 2000-2006 Netfilter Core Team
[    0.645133] TCP cubic registered
[    0.645141] Initializing XFRM netlink socket
[    0.645159] NET: Registered protocol family 17
[    0.645187] Registering the dns_resolver key type
[    0.645234] Using IPI No-Shortcut mode
[    0.645377] registered taskstats version 1
[    0.645392] IMA: No TPM chip found, activating TPM-bypass!
[    0.645463] XENBUS: Device with no driver: device/vbd/51712
[    0.645473] XENBUS: Device with no driver: device/vbd/51776
[    0.645481] XENBUS: Device with no driver: device/vbd/51792
[    0.645490] XENBUS: Device with no driver: device/vif/0
[    0.645498] XENBUS: Device with no driver: device/console/0
[    0.645524]   Magic number: 1:252:3141
[    0.645572] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[    0.645597] Initalizing network drop monitor service
[    0.645715] md: Waiting for all devices to be available before autodetect
[    0.645726] md: If you don't use raid, use raid=noautodetect
[    0.645907] md: Autodetecting RAID arrays.
[    0.645916] md: Scanned 0 and added 0 devices.
[    0.645923] md: autorun ...
[    0.645929] md: ... autorun DONE.
[    0.646031] RAMDISK: Couldn't find valid RAM disk image starting at 0.
[    0.651588] VFS: Cannot open root device "xvda1" or unknown-block(0,0)
[    0.651601] Please append a correct "root=" boot option; here are the available partitions:
[    0.651619] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    0.651632] Pid: 1, comm: swapper Not tainted 2.6.38.6-27.fc15.i686.PAE #1
[    0.651643] Call Trace:
[    0.651659]  [<c07e15f2>] ? printk+0x2d/0x2f
[    0.651670]  [<c07e14cb>] panic+0x5c/0x156
[    0.651683]  [<c0a72d71>] mount_block_root+0x218/0x238
[    0.651695]  [<c04f827f>] ? sys_mknod+0x2c/0x2e
[    0.651705]  [<c0a72f09>] mount_root+0x59/0x5f
[    0.651716]  [<c0a7305d>] prepare_namespace+0x14e/0x192
[    0.651728]  [<c04ece18>] ? sys_access+0x25/0x27
[    0.651739]  [<c0a72aa0>] kernel_init+0x273/0x278
[    0.651749]  [<c0a7282d>] ? kernel_init+0x0/0x278
[    0.651761]  [<c0409c3e>] kernel_thread_helper+0x6/0x10